BinaryFilterExpressionCollectionIndexOf Method

Searches for the specified BinaryFilterExpressionItem in the collection and returns a zero-based index if found.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public int IndexOf(
	BinaryFilterExpressionItem Item
)

Parameters

Item
Type: Tekla.Structures.FilteringBinaryFilterExpressionItem
The item to search for. This value cannot be null.

Return Value

Type: Int32
The zero-based index of the item in the collection. -1 if not found.

Implements

IListTIndexOf(T)
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the supplied item is null.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next