CatalogHandlerImportShapeItems Method

Imports shape geometry items (*.tsc) from specified folder. Import throws exception if model is not open. Import overrides the existing shape items in the catalog without any warnings.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool ImportShapeItems(
	string path
)

Parameters

path
Type: SystemString
The path to be used for import.

Return Value

Type: Boolean
true if successful.
Examples
using System;
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           if (new CatalogHandler().ImportShapeItems(System.IO.Path.GetTempPath()))
               Console.WriteLine("Shape geometries imported successfully to model.");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next