![]() | CatalogHandlerImportMaterialItems Method |
Imports material items (*.lis) from folder to material catalog.
Import overrides the existing materials in the catalog without any warnings.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Parameters
- path
- Type: SystemString
The path to be used for import.
Return Value
Type: Booleantrue if successful.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
using System; using Tekla.Structures.Catalogs; public class Example { public void Example1() { if (new CatalogHandler().ImportMaterialItems(System.IO.Path.GetTempPath())) Console.WriteLine("Materials imported successfully to catalog."); } }
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)