ImageListComboBox Class |
The ImageListComboBox class represents a combo box control that can contain images from an ImageList control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsImageListComboBox
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsImageListComboBox
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The ImageListComboBox type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ImageListComboBox |
Initializes a new instance of the ImageListComboBox class.
|
Properties
Name | Description | |
---|---|---|
DefaultValue |
Gets or sets the default value in the image combo box. If the value is not found,
SelectedItem is used instead.
| |
HoverColor |
Gets or sets the hover color of the combo box.
| |
ImageList |
Gets or sets the ImageList that contains the images to be displayed in the combo box.
Recommended image file formats are JPG and BMP.
| |
SelectedIndex |
Gets or sets the selected index of the image in the image combo box.
| |
SelectedItem |
Gets or sets the selected image in the image combo box. If the image is not found,
SelectedIndex is used instead.
| |
ToolTipText |
Gets or sets the tool tip text.
|
Methods
Name | Description | |
---|---|---|
RefreshOptionList |
Refreshes the option list content.
|
Events
Name | Description | |
---|---|---|
ImageListComboBoxMouseWheel |
The ImageListComboBoxMouseWheel event is triggered just after the mouse wheel has been activated on top of the combo box.
| |
ImageListComboBoxSelectedIndexChanged |
The ImageListComboBoxSelectedIndexChanged event is triggered just after the selected index has been changed in the image combo box.
|
See Also