Image Constructor (ViewBase, Point, Size, String, EmbeddedObjectAttributes) |
Initializes a new instance of the Image class using the specified attributes.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public Image( ViewBase view, Point insertionPoint, Size frameSize, string fileName, EmbeddedObjectAttributes attributes )
Parameters
- view
- Type: Tekla.Structures.DrawingViewBase
The view to be used. - insertionPoint
- Type: Tekla.Structures.Geometry3dPoint
The insertion point to be used. - frameSize
- Type: Tekla.Structures.DrawingSize
The frames size. - fileName
- Type: SystemString
The filename to be used. - attributes
- Type: Tekla.Structures.DrawingEmbeddedObjectAttributes
The attributes to be used.
Exceptions
Exception | Condition |
---|---|
FileNotFoundException | Thrown if the specified file does not exist. |
See Also