IGeometryNode Interface |
The IGeometryNode interface represents geometry tree node. This is implemented by concrete classes for the various types of geometry nodes
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The IGeometryNode type exposes the following members.
Properties
Name | Description | |
---|---|---|
IsAutomatic |
Gets a value indicating whether this geometry node was automatically generated (i.e. false if it was originally a user-defined part)
|
Methods
Name | Description | |
---|---|---|
AcceptVisitor |
Entry method for the visitor pattern
| |
Clone |
Creates a new object that is a copy of the current instance.
|
See Also