ICurve Interface |
Interface that represents an abstract curved geometry defined by a set of points. This interface is intended
to be the base class of 3D curves.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The ICurve type exposes the following members.
Properties
Name | Description | |
---|---|---|
EndPoint |
Gets the end point of the curve. May be the same as StartPoint if the curve is closed.
| |
Length |
Gets the length of the curve
| |
StartPoint |
Gets the start point of the curve
|
Methods
See Also