HyperLink Class

The HyperLink class defines a hyperlink object in a drawing. When a hyperlink is double clicked, the default browser is launched.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class HyperLink : LinkBase

The HyperLink type exposes the following members.

Constructors
  NameDescription
Public methodHyperLink(ViewBase, Point, Uri, String)
Creates a new hyperlink instance using standard attributes.
Public methodHyperLink(ViewBase, Point, Uri, String, LinkAttributes)
Creates a new hyperlink instance using the given attributes.
Public methodHyperLink(ViewBase, Point, Uri, String, Size)
Creates a new hyperlink instance using standard attributes.
Public methodHyperLink(ViewBase, Point, Uri, String, Size, LinkAttributes)
Creates a new hyperlink instance using the given attributes.
Top
Properties
  NameDescription
Public propertyTarget
Gets or sets the target.
Top
Methods
  NameDescription
Public methodDelete
Deletes the link.
(Overrides DatabaseObjectDelete.)
Public methodInsert
Inserts the link.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Modifies the link.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the link.
(Overrides DatabaseObjectSelect.)
Top
Examples
The following example shows how to insert a hyperlink:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;
using System;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           ViewBase _view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase;

           HyperLink link = new HyperLink(_view, new Point(200, 200),
               new Uri("http://www.tekla.com"),
               "Link to Tekla home page");
           link.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next