HyperLink Class

The HyperLink class defines a hyperlink object in a drawing. When a hyperlink is double clicked, the default browser is launched.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class HyperLink : LinkBase

The HyperLink type exposes the following members.

Constructors
  NameDescription
Public methodHyperLink(ViewBase, Point, Uri, String)
Creates a new hyperlink instance using standard attributes.
Public methodHyperLink(ViewBase, Point, Uri, String, LinkAttributes)
Creates a new hyperlink instance using the given attributes.
Public methodHyperLink(ViewBase, Point, Uri, String, Size)
Creates a new hyperlink instance using standard attributes.
Public methodHyperLink(ViewBase, Point, Uri, String, Size, LinkAttributes)
Creates a new hyperlink instance using the given attributes.
Top
Properties
  NameDescription
Public propertyAngle
Gets or sets the angle of the link.
(Inherited from LinkBase.)
Public propertyAttributes
Gets or sets the link attributes.
(Inherited from LinkBase.)
Public propertyInsertionPoint
Gets or sets the insertion point of the link.
(Inherited from LinkBase.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertyTarget
Gets or sets the target.
Public propertyText
Gets or sets the link text that is visible on the screen.
(Inherited from LinkBase.)
Top
Methods
  NameDescription
Public methodDelete
Deletes the link.
(Overrides DatabaseObjectDelete.)
Public methodGetAxisAlignedBoundingBox
Gets the bounding box for the current object in the global axis coordinate system.
(Inherited from LinkBase.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetObjectAlignedBoundingBox
Gets the bounding box for the current object in its local coordinate system.
(Inherited from LinkBase.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Inserts the link.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the link.
(Overrides DatabaseObjectModify.)
Public methodMoveObjectRelative
Moves the object according to the given move vector.
(Inherited from LinkBase.)
Public methodResize
Resizes the object. The scaling type is changed to ScaleToFit.
(Inherited from LinkBase.)
Public methodSelect
Selects the link.
(Overrides DatabaseObjectSelect.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
The following example shows how to insert a hyperlink:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;
using System;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           ViewBase _view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase;

           HyperLink link = new HyperLink(_view, new Point(200, 200),
               new Uri("http://www.tekla.com"),
               "Link to Tekla home page");
           link.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next