HierarchicObject Constructor (Identifier)

Instantiates a hierarchical object with a known identifier. The instantiation has to be done before the hierarchical definition instance can be selected.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public HierarchicObject(
	Identifier ID
)

Parameters

ID
Type: Tekla.StructuresIdentifier
The identifier of an existing hierarchical object.
Examples
using Tekla.Structures.Model;
using Tekla.Structures;

public class Example
{
       public void Example1()
       {
           Identifier id = new Identifier(357);

           HierarchicObject hierarchicalObject = new HierarchicObject(id);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next