HelpViewer Class |
Class for viewing help files with Tekla Structures HelpViewer.exe.
Inheritance Hierarchy
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The HelpViewer type exposes the following members.
Methods
Name | Description | |
---|---|---|
DisplayHelpTopic |
Method for opening Tekla Structures help viewer with given help topic.
Method requires Tekla Structures to be running.
| |
DisplayHelpTopicIndependent |
Method for opening Tekla Structures help viewer independently from given file path with given help topic and language.
|
Examples
using System; using Tekla.Structures.Dialog; public class Example { public bool Example1() { // [*] Help root location is defined in registry key "HelpLocation". "HelpLocation" registry key's path is defined in HelpViewer.exe's configration file. // Tekla Structures is running and file "example_help_topic" is located at // location[*]\[Language] folder where [language] is active language in Tekla Structures. HelpViewer.DisplayHelpTopic("example_help_topic"); // If Tekla Structures is not running, HelpViewer can be started independently by providing the path to the HelpViewer.exe, help topic and language. HelpViewer.DisplayHelpTopicIndependent(@"D:\CustomPath\HelpViewer.exe", "example_help_topic", "enu"); } }
See Also