HatchAttributes Class |
The HatchAttributes base class, inherited by ModelObjectHatchAttributes
and GraphicObjectHatchAttributes, contains hatch attributes.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingHatchAttributes
Tekla.Structures.DrawingGraphicObjectHatchAttributes
Tekla.Structures.DrawingModelObjectHatchAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingHatchAttributes
Tekla.Structures.DrawingGraphicObjectHatchAttributes
Tekla.Structures.DrawingModelObjectHatchAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The HatchAttributes type exposes the following members.
Properties
Name | Description | |
---|---|---|
Angle |
The angle in which to draw the hatch.
| |
BackgroundColor |
The background color of the hatch.
| |
Color |
The color of the hatch.
| |
DrawBackgroundColor |
Sets whether the background color will be enabled or disabled for the hatch.
See also: BackgroundColor.
| |
FactorType |
The type of the hatch factor.
| |
Name |
The name of the hatch.
If an empty string is given as hatch name it will become "None".
| |
ScaleX |
The scale value of the hatch in the X-direction.
| |
ScaleY |
The scale value of the hatch in the Y-direction.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Inherited from GenericAttributesBase.) |
See Also