GridLineGridLabel Class |
The GridLabel class contains the grid labels of the grid lines, the text label and the insertion points.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The GridLineGridLabel type exposes the following members.
Constructors
Name | Description | |
---|---|---|
GridLineGridLabel |
Creates a new default grid label instance.
|
Properties
Name | Description | |
---|---|---|
CenterPoint |
The center point of the grid label.
| |
FrameHeight |
The height of the grid label frame.
| |
FrameWidth |
The width of the grid label frame.
| |
GridLabelPoint |
The grid line's label point.
If the value of GridLabelPoint differs from the OffsetGridPoint value,
a leader line will be created to the GridLabelPoint position.
You can remove the leader line by setting GridLabelPoint to the GridPoint value
(or by setting the GridLabelPoint anywhere on the grid line, but then the offset will change).
| |
GridLabelText |
The grid line's label text.
| |
GridPoint |
The grid line point, without offsets taken into consideration (model grid line coordinates).
| |
OffsetGridPoint |
The grid line point where the grid line actually ends, with offsets applied.
| |
TextHeight |
The height of the grid label's text frame.
| |
TextWidth |
The width of the grid label's text frame.
|
Methods
Name | Description | |
---|---|---|
GetAxisAlignedBoundingBox |
The bounding box of the grid line label (rectangle format, axis aligned).
| |
GetAxisAlignedBoundingBoxOfTextLabel |
The bounding box of the grid line label's text (rectangle format, axis aligned).
| |
MoveObjectRelative |
Moves the object using the move vector.
|
See Also