GridLine Class |
The GridLine class contains methods related to grid lines.
A drawing grid line is always a child of a grid object.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingGridLine
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingGridLine
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The GridLine type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
The attributes of the grid line.
For more information see GridLineGridLineAttributes.
| |
EndLabel |
The end of the grid line, contains the grid label and position information.
For more information see GridLineGridLabel.
| |
Hideable |
Accesses the information if this object is hidden or not or if it should be.
(Inherited from ModelObject.) | |
ModelIdentifier |
The database identifier of the model object in the model database.
By using this identifier, it is possible to select the actual object
in the Tekla Structures model.
(Inherited from ModelObject.) | |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) | |
StartLabel |
The beginning of the grid line, contains the grid label and position information.
For more information see GridLineGridLabel.
|
Methods
Name | Description | |
---|---|---|
Delete |
GridLines cannot be deleted.
(Overrides DatabaseObjectDelete.) | |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) | |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) | |
Insert |
GridLines cannot be inserted.
(Overrides DatabaseObjectInsert.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Calls the system to update/modify the object.
(Overrides DatabaseObjectModify.) | |
Select |
Calls the system to select and retrieve the object.
(Overrides DatabaseObjectSelect.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |
Examples
using Tekla.Structures.Drawing; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Drawing MyDrawing = new GADrawing(); View curview = new View(MyDrawing.GetSheet(), new CoordinateSystem(), new CoordinateSystem(), new AABB(new Point(), new Point(30000, 30000, 10000))); DrawingObjectEnumerator allObjects = curview.GetAllObjects(); Grid curGrid = allObjects.Current as Grid; GridLine curGridLine; DrawingObjectEnumerator allGridLines = curGrid.GetObjects(); while(allGridLines.MoveNext()) /* Iterate through all the grid lines of the grid */ { if(allGridLines.Current is GridLine) { curGridLine = allGridLines.Current as GridLine; curGridLine.Attributes.DrawTextAtStartOfGridLine = true; curGridLine.Attributes.DrawTextAtEndOfGridLine = true; curGridLine.Attributes.Font.Color = DrawingColors.Red; // The following code moves the grid labels off the grid lines by 200. curGridLine.StartLabel.GridLabelPoint.Y = curGridLine.StartLabel.GridPoint.Y + 200; curGridLine.EndLabel.GridLabelPoint.Y = curGridLine.EndLabel.GridPoint.Y + 200; curGridLine.Modify(); /* Apply changes */ } } } }
See Also