GraphicPolyLine Class |
Inheritance Hierarchy
Namespace: Tekla.Structures.Model.UI
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The GraphicPolyLine type exposes the following members.
Constructors
Name | Description | |
---|---|---|
GraphicPolyLine |
Create a black line with width 1 and solid line type.
| |
GraphicPolyLine(Color, Int32, GraphicPolyLineLineType) |
Create a graphic polyline object with 0 points.
| |
GraphicPolyLine(PolyLine, Color, Int32, GraphicPolyLineLineType) |
Create a graphic polyline object.
|
Properties
Name | Description | |
---|---|---|
Color |
The line color.
| |
PolyLine |
The path of the line.
| |
Type |
The appearance of the line. For instance solid, dashed or dotted.
| |
Width |
The line width in pixels.
NOTE: Currently the valid width values are 1, 2 and 4
|
See Also