DatabaseObjectGetStringUserProperties Method (ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public bool GetStringUserProperties( List<string> names, out Dictionary<string, string> values )
Parameters
- names
- Type: System.Collections.GenericListString
List of names to get the values for. - values
- Type: System.Collections.GenericDictionaryString, String
Dictionary of name/value pairs that contain the values of the found user properties with the given names.
Return Value
Type: BooleanTrue if the request succeeded (the returned values can still be empty if no such UserProperties were found).
See Also