ReinforcementGetSingleRebar Method |
Returns a single rebar inside the rebar group located by the given index.
The indexing starts from the start point. The rebar represents a physical reinforcing bar
and contains physical points in the 3D space of the bar.
The method returns null on error, for example if given an erroneous index.
The number of rebars in the group can be requested with GetNumberOfRebars().
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Parameters
- index
- Type: SystemInt32
The index of the rebar in the group. - withHooks
- Type: SystemBoolean
A parameter to determine whether the hook points should be included in the rebar geometry or not.
Return Value
Type: RebarGeometryThe instance of a RebarGeometry object that contains the point list of the single physical reinforcing bar. Null if the given index was not valid.
See Also