ReinforcementGetRebarComplexGeometries Method (Boolean, Boolean, Boolean)

Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. RebarComplexGeometry only differs from RebarGeometry by containing a polycurve rather than a polyline.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public List<RebarComplexGeometry> GetRebarComplexGeometries(
	bool withHooks,
	bool withoutClashes,
	bool lengthAdjustments
)

Parameters

withHooks
Type: SystemBoolean
A parameter to determine whether the hook points should be included in the rebar geometry or not.
withoutClashes
Type: SystemBoolean
A parameter to determine whether self-clash avoidance should be included in the rebar geometry or not.
lengthAdjustments
Type: SystemBoolean
A parameter to determine whether rounding and step tapering should be included in the rebar geometry or not.

Return Value

Type: ListRebarComplexGeometry
A list of RebarComplexGeometrys.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next