UserPropertyItemGetOptions Method (ListKeyValuePairInt32, String, Boolean) |
Gets the value options of an integer property.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool GetOptions( ref List<KeyValuePair<int, string>> IntOptions, bool translatedLabels )
Parameters
- IntOptions
- Type: System.Collections.GenericListKeyValuePairInt32, String
The value options. - translatedLabels
- Type: SystemBoolean
if set to true labels translated to current language are returned, otherwise the resource key of label is returned.
Return Value
Type: BooleanTrue on success.
See Also