UserPropertyItemGetOptions Method (ListKeyValuePairDouble, String, Boolean) |
Gets the value options of a double property.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool GetOptions( ref List<KeyValuePair<double, string>> DoubleOptions, bool translatedLabels )
Parameters
- DoubleOptions
- Type: System.Collections.GenericListKeyValuePairDouble, String
The value options. - translatedLabels
- Type: SystemBoolean
if set to true labels translated to current language are returned, otherwise the resource key of label is returned.
Return Value
Type: BooleanTrue on success.
See Also