ModelHistoryGetModifiedObjectsWithType Method |
Note: This API is now obsolete.
Gets based on type a list of the objects that have been added or modified after the modification stamp.
Namespace: Tekla.Structures.Model.History
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[ObsoleteAttribute("Use TakeModifications() instead.")] public static ModelObjectEnumerator GetModifiedObjectsWithType( ModificationStamp ModStamp, ModelObjectModelObjectEnum Enum )
Parameters
- ModStamp
- Type: Tekla.Structures.Model.HistoryModificationStamp
The modification stamp. - Enum
- Type: Tekla.Structures.ModelModelObjectModelObjectEnum
The type of the objects to return.
Return Value
Type: ModelObjectEnumeratorA list of the objects that have been modified after the given modification stamp.
See Also