ModelHistoryGetModifications Method (String, ModificationStamp)

Lookup modifications since previous call of TakeModifications() without resetting the modstamp

Namespace:  Tekla.Structures.Model.History
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public static ModificationInfo GetModifications(
	string Name,
	ModificationStamp PrevStamp = null
)

Parameters

Name
Type: SystemString
Name of reference which is used for collecting modifications and which is updated. Intended use is to assign an unique name for each client application which needs to be informed of the model updates. Maximum length is 79 characters.
PrevStamp (Optional)
Type: Tekla.Structures.Model.HistoryModificationStamp
When specified, default value of reference if is it not found

Return Value

Type: ModificationInfo
All modifications which happened since the last call
Remarks
Takes modification which has happened to the model since the previous call to TakeModifications with the same Name argument. If there was no previous call of TakeModifications() with this Name, shows modifications since beginning, or since PrevStap, if it is specified.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next