PluginGetIntAttribute Method

Gets the value of the specified int attribute of the plug-in.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public int GetIntAttribute(
	string FieldName
)

Parameters

FieldName
Type: SystemString
The name of the attribute to get.

Return Value

Type: Int32
The value of the attribute, or 0 if the plug-in does not have such an attribute.
Exceptions
ExceptionCondition
CannotGetAttributeForPluginException Thrown when the getting of the attribute failed for an unknown reason (might indicate an invalid plug-in name).
CannotGetAttributeForPluginDueToIncorrectTypeException Thrown when getting a value with an invalid type for the specified field.
CannotGetAttributeForPluginDueToInexistantFieldException Thrown when getting the value of an inexistent field.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next