ModelObjectSelectorGetFilteredObjectsWithType Method

Returns an enumerator of the model objects in the current model with the given type and selected by the filter.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ModelObjectEnumerator GetFilteredObjectsWithType(
	ModelObjectModelObjectEnum Enum,
	string FilterName
)

Parameters

Enum
Type: Tekla.Structures.ModelModelObjectModelObjectEnum
The type of the objects to return.
FilterName
Type: SystemString
The name of an existing selection filter to apply.

Return Value

Type: ModelObjectEnumerator
A model object enumerator of the model objects with the given type and selected by the filter.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next