EnvironmentFilesGetAttributeFile Method (ListString, String)

Note: This API is now obsolete.

Gets a file info representing the first match in the search directories.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
[ObsoleteAttribute("Deprecated. Please use GetAttributeFile(string fileName) instead.", 
	false)]
public static FileInfo GetAttributeFile(
	List<string> searchDirectories,
	string fileName
)

Parameters

searchDirectories
Type: System.Collections.GenericListString
The list of directories to be used for searching for the file.
fileName
Type: SystemString
The name of the file including the file extension.

Return Value

Type: FileInfo
A file info for the first match in the directory list. Null if no match was found.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next