GeometricPlane Class |
The GeometricPlane class represents a 3d geometric plane.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The GeometricPlane type exposes the following members.
Constructors
Name | Description | |
---|---|---|
GeometricPlane |
Instantiates an XY-plane with the origin at (0,0,0).
| |
GeometricPlane(CoordinateSystem) |
Instantiates a plane defined by the given coordinate system.
| |
GeometricPlane(Point, Vector) |
Instantiates a plane defined by the given origin point and normal vector.
| |
GeometricPlane(Point, Vector, Vector) |
Instantiates a plane defined by the given origin, X-axis vector and Y-axis vector.
|
Properties
Methods
See Also