DistanceFromFractionalFeetAndInchesString Method (String)

Creates a distance from a string representation of fractional feet and inches.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
public static Distance FromFractionalFeetAndInchesString(
	string text
)

Parameters

text
Type: SystemString
The distance string.

Return Value

Type: Distance
The representation of the specified distance.
Exceptions
ExceptionCondition
FormatExceptionThrown if the text does not represent a distance.
Examples
This example shows how to parse a Distance instance from a fractional string representation of feet and inches.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           Distance distance = Distance.FromFractionalFeetAndInchesString("3' 3/4");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next