FormingStates Class |
FormingStates class which contains different forming options.
Inheritance Hierarchy
Namespace: Tekla.Structures.Forming
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The FormingStates type exposes the following members.
Constructors
Name | Description | |
---|---|---|
FormingStates |
Initializes a new instance of the FormingStates class.
| |
FormingStates(DeformingType) |
Initializes a new instance of the FormingStates class.
| |
FormingStates(FoldingType) |
Initializes a new instance of the FormingStates class.
| |
FormingStates(WrappingType) |
Initializes a new instance of the FormingStates class.
| |
FormingStates(DeformingType, FoldingType, WrappingType) |
Initializes a new instance of the FormingStates class.
|
Properties
Name | Description | |
---|---|---|
Deforming |
Gets or sets the deforming type.
| |
Folding |
Gets or sets the folding type.
| |
Wrapping |
Gets or sets the wrapping type.
|
Methods
See Also