FormatTypes Enumeration

The available format types.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public enum FormatTypes
Members
  Member nameValueDescription
Automatic0Automatic, chooses the most appropriate format for the current environment.
WholeNumber1As shown on the dialog: ###. This format will not show fractions or decimals.
OneDecimalIfValidDecimal2As shown on the dialog: ###.[#]. This format will not show fractions or decimals, unless the rounded decimal part is a non zero value.
OneDecimal3As shown on the dialog: ###.#. This format will always show the value with one decimal.
TwoDecimalsIfValidDecimals4As shown on the dialog: ###.[##]. This format will not show fractions or decimals, unless the rounded decimal part is a non zero value.
TwoDecimals5As shown on the dialog: ###.##. This format will always show the value with two decimals.
ThreeDecimalsIfValidDecimals6As shown on the dialog: ###.[###]. This format will not show fractions or decimals, unless the rounded decimal part is a non zero value.
ThreeDecimals7As shown on the dialog: ###.###. This format will always show the value with three decimals.
Fractional8As shown on the dialog: ### #/#. This format will always show the value with fractions.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next