FormBorders Class |
The FormBorders class handles the storing and restoring of the form size and location.
Inheritance Hierarchy
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The FormBorders type exposes the following members.
Methods
Name | Description | |
---|---|---|
CheckScreenPosition(Form) |
Moves form to primary screen.
| |
CheckScreenPosition(Window) |
Moves window to primary screen.
| |
IsOnActiveDisplays |
Checks form quadrants to be sure full extents is on a single screen
| |
RestoreFormSizeAndLocation(Form) |
Restores the form size and location from the registry.
| |
RestoreFormSizeAndLocation(Window) |
Restores the WPF window size and location from the registry.
| |
StoreFormSizeAndLocation(Form) |
Stores the form size and location into the registry.
| |
StoreFormSizeAndLocation(Window) |
Stores the window size and location into the registry.
|
See Also