FormBase Methods

The FormBase type exposes the following members.

Methods
  NameDescription
Public methodApplyValues
Loads the dialog values from a file and performs Apply on the loaded values. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
Public methodGetConnectionStatus
Returns true if a proper connection to the Tekla Structures process has been established. Currently, there's no way to re-establish the connection.
Public methodStatic memberGetUnitDecimals
Gets the number of decimals Tekla Structures uses with the specified unit type.
Public methodStatic memberInitializeAngleUnitDecimals
Gets the number of decimals Tekla Structures uses for displaying the angle unit and initializes Angle class to use that.
Public methodStatic memberInitializeDistanceUnitDecimals
Gets the number of decimals Tekla Structures uses for displaying the "length" unit and initializes the distance datatype to use that.
Public methodInitializeForm
Prepares the data storage for the dialog and scans through the fields.
Public methodStatic memberInitializeUnitDecimals
Gets the number of decimals Tekla Structures uses for displaying its units and initializes the Tekla.Structures.Datatype classes to use them.
Public methodLoadValues
Loads the dialog values from a file. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
Public methodModifyValues
Loads the dialog values from a file and performs Modify on the loaded values. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
Public methodSaveValues
Serializes the dialog values to an xml file.
Public methodCode exampleSetAttributeValue
Sets a value for the given control. When the dialog is not shown, setting a property directly for a control (such as textBox1.Text = "text") will not work for controls that have a Tekla Structures AttributeTypeName set. This method is going to have to be used to set the value.
Public methodShowForm
Displays the form.
Public methodUpdateValues Obsolete.
Rereads and updates all the field values on the form.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next