FacetedBrepWithNormals Class |
The FacetedBRepWithNormals class defines a faceted BREP that has also vertex normal vectors.
Inheritance Hierarchy
SystemObject
Tekla.Structures.Geometry3dFacetedBrep
Tekla.Structures.Geometry3dFacetedBrepWithNormals
Tekla.Structures.Geometry3dFacetedBrep
Tekla.Structures.Geometry3dFacetedBrepWithNormals
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The FacetedBrepWithNormals type exposes the following members.
Constructors
Name | Description | |
---|---|---|
FacetedBrepWithNormals |
Initializes a new instance of the FacetedBrepWithNormals class.
|
Properties
Name | Description | |
---|---|---|
Faces |
Gets the faces.
(Inherited from FacetedBrep.) | |
GetEdges |
Gets the edges.
(Inherited from FacetedBrep.) | |
InnerWires |
Gets the inner wires.
(Inherited from FacetedBrep.) | |
Normals |
Gets or sets the vertex normal unit vectors
| |
OuterWires |
Gets the outer wires.
(Inherited from FacetedBrep.) | |
Vertices |
Gets the vertices.
(Inherited from FacetedBrep.) |
Methods
Name | Description | |
---|---|---|
CheckForTwoManifold |
Gets a value indicating whether this instance is 2-manifold.
(Inherited from FacetedBrep.) | |
GetInnerFace |
Gets the inner face at the specified index.
(Inherited from FacetedBrep.) | |
GetInnerFaceCount |
Gets the inner face count of the outer face at the specified index.
(Inherited from FacetedBrep.) | |
GetOuterFace |
Gets the outer face at the specified index.
(Inherited from FacetedBrep.) |
Examples
public void Example() { /* See the method <b>InsertUsingNormals</b> in the <b>ShapeItem</b> class for a code example*/ }
See Also