FacetedBrep Constructor (Vector, Int32, IDictionaryInt32, Int32, IListIndirectPolymeshEdge) |
Initializes a new instance of the FacetedBrep class.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public FacetedBrep( Vector[] vertices, int[][] outerWires, IDictionary<int, int[][]> innerWires, IList<IndirectPolymeshEdge> edges )
Parameters
- vertices
- Type: Tekla.Structures.Geometry3dVector
Vector of the faceted brep vertices. - outerWires
- Type: SystemInt32
outerWires is an array of integer arrays, providing indices in the traversing order for each outer loop/wire. The indices correspond to the position of a vertex in the vertices array." - innerWires
- Type: System.Collections.GenericIDictionaryInt32, Int32
innerWires is an array of integer arrays, providing indices in the traversing order for each inner loop/wire. The dictionary key for the innerWires is the Face index (0-origin). The indices correspond to the position of a vertex in the vertices array." - edges
- Type: System.Collections.GenericIListIndirectPolymeshEdge
The edge information as indirect edges.
See Also