Face Class

The Face class represents a single face in a solid.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.SolidFace

Namespace:  Tekla.Structures.Solid
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public sealed class Face

The Face type exposes the following members.

Properties
  NameDescription
Public propertyNormal
The normal vector of the face.
Public propertyOriginPartId
The part id of the part that this face originated from. For example, a face create by a part cut has the id of the cutting part.
Top
Methods
  NameDescription
Public methodGetLoopEnumerator
Gets a new loop enumerator for enumerating through the face's loops.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next