ProfileItemExport Method |
Exports the profile item in the profile database to given file name.
Currently library profiles, sketch profiles and clb profiles are supported.
Library profiles are exported to *.lis format.
Sketch profiles are exported to *.uel format.
Clb profiles are exported to *.clb format.
If path is not given profile is exported to model folder.
If filename is empty profile name or prefix is used as filename.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
Parameters
- filename
- Type: SystemString
The export file name of the profile item.
Return Value
Type: BooleanTrue on success.
Examples
using System; using Tekla.Structures.Catalogs; public class Example { public void Example1() { LibraryProfileItem item = new LibraryProfileItem(); if (item.Select("HEA100")) { string filename = System.IO.Path.GetTempPath() + "\\" + "HEA100"; if (item.Export(ref filename)) { Console.WriteLine("HEA100 exported successfully"); } } } }
See Also