DrawingItemExport Method

Exports the drawing item in the catalog to given file name. If path is not given drawing is exported to model folder. If filename is empty drawing name is used as filename.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool Export(
	ref string filename
)

Parameters

filename
Type: SystemString
The export file name of the drawing item.

Return Value

Type: Boolean
True on success.
Examples
using System;
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           DrawingItem item = new DrawingItem();

           if (item.Select())
           {
               string filename = System.IO.Path.GetTempPath() + item.Name;
               if (item.Export(ref filename))
               {
                   Console.WriteLine(item.Name + " exported successfully");
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next