EmbeddedObjectFrame Class

The EmbeddedObjectFrame class defines the frame object for embedded objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingEmbeddedObjectFrame

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class EmbeddedObjectFrame : IAxisAlignedBoundingBox, 
	IObjectAlignedBoundingBox, IIsEqual

The EmbeddedObjectFrame type exposes the following members.

Constructors
  NameDescription
Public methodEmbeddedObjectFrame
Creates a new embedded object frame instance with the specified line type and color.
Top
Properties
  NameDescription
Public propertyColor Obsolete.
Public propertyLine
Gets or sets the line type of the frame.
Public propertyLineType Obsolete.
Public propertyType
Gets the frame type (rectangular).
Top
Methods
  NameDescription
Public methodGetAxisAlignedBoundingBox
Returns the bounding box of the frame in the global axis coordinate system.
Public methodGetObjectAlignedBoundingBox
Returns the bounding box of the frame in the local coordinate system.
Public methodIsEqual
Compares the current object with an object of the same type.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next