AttributeTypeNameEditorEditValue Method |
Edits the specified object's value using the editor style indicated by the GetEditStyle method.
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public override Object EditValue( ITypeDescriptorContext context, IServiceProvider provider, Object value )
Parameters
- context
- Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information. - provider
- Type: SystemIServiceProvider
An IServiceProvider that the editor can use to obtain services. - value
- Type: SystemObject
The object to edit.
Return Value
Type: ObjectThe new value of the object. If the value of the object has not changed, this should return the same object it was passed.
See Also