Edge Class

The Edge class represents a single global edge in a solid.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.SolidEdge

Namespace:  Tekla.Structures.Solid
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public sealed class Edge : ICloneable

The Edge type exposes the following members.

Properties
  NameDescription
Public propertyEndPoint
Gets the end point of the edge.
Public propertyStartPoint
Gets the start point of the edge.
Public propertyType
Gets the type of the edge.
Top
Methods
  NameDescription
Public methodClone
Method for cloning the current object.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next