EdgeChamferEdgeChamferAttributes Class |
The EdgeChamferAttributes class is the attributes class for the edge chamfer.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingEdgeChamferEdgeChamferAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingEdgeChamferEdgeChamferAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The EdgeChamferEdgeChamferAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
EdgeChamferEdgeChamferAttributes |
Creates a new default edge chamfer attributes instance that loads standard attributes.
| |
EdgeChamferEdgeChamferAttributes(String) |
Creates a new edge chamfer attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
VisibleLines |
The line type of the chamfer.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also