DwgObject Class

The DwgObject class defines a DWG or DXF object that can be inserted into a drawing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class DwgObject : EmbeddedObjectBase

The DwgObject type exposes the following members.

Constructors
  NameDescription
Public methodDwgObject(ViewBase, Point, String)
Creates a new DwgObject instance with the given parameters.
Public methodDwgObject(ViewBase, Point, String, EmbeddedObjectAttributes)
Creates a new DwgObject instance using the specified attributes.
Public methodDwgObject(ViewBase, Point, Size, String)
Creates a new DwgObject instance with the given parameters.
Public methodDwgObject(ViewBase, Point, Size, String, EmbeddedObjectAttributes)
Creates a new DwgObject instance using the specified attributes.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Top
Examples
The following example shows how to embed a DXF file to a drawing with the scale 0.5:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;
using System.IO;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           ViewBase _view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase;

           EmbeddedObjectAttributes attributes = new EmbeddedObjectAttributes();
           attributes.XScale = 0.5;
           attributes.YScale = 0.5;
           DwgObject dxf = new DwgObject(_view, new Point(100, 100),
                                         Path.GetFullPath("my_dxf.dxf"), attributes);
           dxf.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next