DrawingSelector Class |
The DrawingSelector class provides functionality for accessing the drawing list dialog.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing.UI
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The DrawingSelector type exposes the following members.
Methods
Name | Description | |
---|---|---|
GetSelected |
Gets the drawings that are currently selected in the drawing list dialog.
|
Examples
The following example deletes the selected drawings:
using Tekla.Structures.Drawing; public class Example { public void Example1() { DrawingHandler MyDrawingHandler = new DrawingHandler(); if(MyDrawingHandler.GetConnectionStatus()) { DrawingEnumerator SelectedDrawings = MyDrawingHandler.GetDrawingSelector().GetSelected(); while(SelectedDrawings.MoveNext()) { SelectedDrawings.Current.Delete(); } } } }
See Also