DrawingPluginBaseUpdateMode Enumeration |
Defines the update mode of the drawing plug-in.
The update mode tells the system when the plug-in is executed.
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
CREATE_ONLY | 0 | The plug-in is never updated. Plug-ins are executed from the plug-in dialog instead of the component catalog. The created objects do not have any relation to the plug-in anymore. The plug-in dialog cannot be opened from the created objects. | |
INPUT_CHANGED | 1 | The plug-in is updated when the input is a point and the point is moved or when the input is an object and the object changes. The plug-in is executed when the input is an object and its properties are changed in the drawing editor. This mode is the default which is used if the update mode is not defined in the plug-in source. | |
DRAWING_OPENED | 2 | The plug-in is updated also when a drawing is opened. The plug-in is executed when the input is changed or during drawing opening. |
See Also