DrawingPluginBaseInputDefinitionInputTypes Enumeration

The possible input types for a drawing plug-in.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public enum InputTypes
Members
  Member nameValueDescription
INPUT_ONE_POINT1 The input has one point.
INPUT_TWO_POINTS2 The input has two points.
INPUT_THREE_POINTS3 The input has three points.
INPUT_N_POINTS4 The input has multiple points.
INPUT_ONE_OBJECT5 The input has one drawing object. The supported drawing objects are bolts, parts and rebars. Bolts, parts and rebars are drawing objects derived from model objects. The parts include the beam, the contour plate and the polybeam.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next