DrawingPluginBaseInputDefinition Class |
The InputDefinition class is a class for defining the plug-in dependency over the input (points or identifiers).
The user implemented method DefineInput() of the DrawingPluginBase interface should return an array list of
input definition instances. This defines the points and identifiers the plug-in will receive as input
when the Run() method is called.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
The DrawingPluginBaseInputDefinition type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DrawingPluginBaseInputDefinition(Identifier, ListPoint) |
Creates a new input definition with multiple points.
| |
DrawingPluginBaseInputDefinition(Identifier, Point) |
Creates a new input definition instance with one point.
| |
DrawingPluginBaseInputDefinition(Identifier, Identifier) |
Creates a new input definition instance with one identifier.
| |
DrawingPluginBaseInputDefinition(Identifier, Point, Point) |
Creates a new input definition instance with two points.
| |
DrawingPluginBaseInputDefinition(Identifier, Point, Point, Point) |
Creates a new input definition instance with three points.
|
Properties
Name | Description | |
---|---|---|
Type |
The type of the input the current instance contains.
| |
ViewId |
The view object's identifier.
|
Methods
Name | Description | |
---|---|---|
GetInput |
Returns the input Tekla Structures gave to the plug-in. The input is either a point instance,
an identifier instance, an array list of points or an array list of identifiers. This is based on the input
format returned from the DefineInput() method.
|
See Also