DrawingObjectNoAttributes Class

The NoAttributes class defines attributes for objects that do not contain any attributes.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingDrawingObjectNoAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class NoAttributes : AttributesBase

The DrawingObjectNoAttributes type exposes the following members.

Constructors
  NameDescription
Public methodDrawingObjectNoAttributes
Creates a new default no attributes instance.
Public methodDrawingObjectNoAttributes(String)
Creates a new no attributes instance. No attributes are loaded from the attribute file as it is not possible to load attributes for objects of this type.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).)
Public methodLoadAttributes
It is not possible to load attributes for objects of this type because the objects have no attributes.
(Overrides AttributesBaseLoadAttributes(String).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next