DrawingObjectEnumerator Class

The DrawingObjectEnumerator class provides the means to iterate through drawing object instances. Drawing object enumerators are generated by the container view and they contain drawing objects that are children of the container view instance.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public sealed class DrawingObjectEnumerator : DrawingEnumeratorBase

The DrawingObjectEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Gets the current drawing object.
Top
Methods
  NameDescription
Top
Fields
  NameDescription
Top
Examples
using Tekla.Structures.Drawing;

public class Example
{
       public void Example1()
       {
           DrawingHandler DrawingHandler = new DrawingHandler();
           Drawing CurrentDrawing = DrawingHandler.GetActiveDrawing();

           // Loop through all objects in the drawing and delete all existing line objects.
           DrawingObjectEnumerator AllObjects = CurrentDrawing.GetSheet().GetAllObjects();

           while(AllObjects.MoveNext())
           {
               if(AllObjects.Current is Line)
               {
                   AllObjects.Current.Delete();
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next