DrawingLink Class |
The DrawingLink class defines a drawing link object in a drawing.
When a drawing link is double clicked, the target drawing is opened.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingLinkBase
Tekla.Structures.DrawingDrawingLink
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingLinkBase
Tekla.Structures.DrawingDrawingLink
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The DrawingLink type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DrawingLink(ViewBase, Point, Drawing, String) |
Creates a new drawing link instance using standard attributes.
| |
DrawingLink(ViewBase, Point, Drawing, String, LinkAttributes) |
Creates a new drawing link instance using the given attributes.
| |
DrawingLink(ViewBase, Point, Drawing, String, Size) |
Creates a new drawing link instance of the given size.
| |
DrawingLink(ViewBase, Point, Drawing, String, Size, LinkAttributes) |
Creates a new drawing link instance of the given size.
|
Properties
Name | Description | |
---|---|---|
Angle |
Gets or sets the angle of the link.
(Inherited from LinkBase.) | |
Attributes |
Gets or sets the link attributes.
(Inherited from LinkBase.) | |
InsertionPoint |
Gets or sets the insertion point of the link.
(Inherited from LinkBase.) | |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) | |
Target |
Gets or sets the target drawing.
| |
Text |
Gets or sets the link text that is visible on the screen.
(Inherited from LinkBase.) |
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the link.
(Overrides DatabaseObjectDelete.) | |
GetAxisAlignedBoundingBox |
Gets the bounding box for the current object in the global axis coordinate system.
(Inherited from LinkBase.) | |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetObjectAlignedBoundingBox |
Gets the bounding box for the current object in its local coordinate system.
(Inherited from LinkBase.) | |
GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) | |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) | |
Insert |
Inserts the link.
(Overrides DatabaseObjectInsert.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Modifies the link.
(Overrides DatabaseObjectModify.) | |
MoveObjectRelative |
Moves the object according to the given move vector.
(Inherited from LinkBase.) | |
Resize |
Resizes the object. The scaling type is changed to ScaleToFit.
(Inherited from LinkBase.) | |
Select |
Selects the link.
(Overrides DatabaseObjectSelect.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |
Examples
The following example shows how to create a basic drawing link to the current drawing.
The drawing mark is used as the link text.
using Tekla.Structures.Drawing; using Tekla.Structures.Geometry3d; using System; public class Example { public void Example1() { DrawingHandler _drawingHandler = new DrawingHandler(); ViewBase _view = _drawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase; Size size = new Size(10.0, 10.0); Point insertionPoint = new Point(200, 200); DrawingLink link = new DrawingLink(_view, insertionPoint, _drawingHandler.GetActiveDrawing(), String.Empty, size); link.Insert(); } }
See Also