DrawingEnumerator Class |
The DrawingEnumerator class provides the means to iterate through drawing instances. Drawing enumerators
are generated by the drawing handler.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDrawingEnumeratorBase
Tekla.Structures.DrawingDrawingEnumerator
Tekla.Structures.DrawingDrawingEnumeratorBase
Tekla.Structures.DrawingDrawingEnumerator
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The DrawingEnumerator type exposes the following members.
Properties
Methods
Name | Description | |
---|---|---|
Fields
Name | Description | |
---|---|---|
Examples
using Tekla.Structures.Drawing; public class Example { public void Example1() { DrawingHandler DrawingHandler = new DrawingHandler(); // Loop through all available drawings and delete all GA drawings. DrawingEnumerator AllDrawings = DrawingHandler.GetDrawings(); while(AllDrawings.MoveNext()) { Drawing CurrentDrawing = AllDrawings.Current as GADrawing; if(CurrentDrawing != null) { CurrentDrawing.Delete(); } } } }
See Also