GraphicsDrawerDrawText Method

Draws a temporary text in the currently active rendered view.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public bool DrawText(
	Point Location,
	string Text,
	Color Color
)

Parameters

Location
Type: Tekla.Structures.Geometry3dPoint
The location of the text's top-left corner.
Text
Type: SystemString
The text to be drawn. The maximum length is 511 characters.
Color
Type: Tekla.Structures.Model.UIColor
The color of the text. The transparency value of the color is ignored.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next