Double Structure |
The Double datatype.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
The Double type exposes the following members.
Constructors
Properties
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares the current object with another object of the same type.
| |
Equals(Object) |
Returns a value that indicates whether the current instance is equal to the given object.
(Overrides ValueTypeEquals(Object).) | |
Equals(Double) |
Indicates whether the current object is equal to another object of the same type.
| |
GetHashCode |
Returns the hash code for the current instance.
(Overrides ValueTypeGetHashCode.) | |
GetSchema |
Gets the XML Schema for the datatype.
| |
ReadXml |
Parses a new value from the given reader.
| |
ToString |
Returns the string representation of the object.
(Overrides ValueTypeToString.) | |
WriteXml |
Writes the value as XML to the given writer.
|
Operators
Name | Description | |
---|---|---|
Equality |
Compares a double value with a Datatype.Double value.
| |
(Double to Double) |
Converts from double to Datatype.Double.
| |
(Double to Double) |
Converts from Datatype.Double to double.
| |
Inequality |
Compares a double value with a Datatype.Double value.
|
See Also